<!DOCTYPE html>
<html lang="en" class="no-js">
  <head>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" /><script type="text/javascript">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</script>
<meta property="og:type" content="article" />
<meta property="og:url" content="http://kazu.org/post/after-putins-offer-share-notes-ranking-house-intel-democrat-schiff-running-out-expletives" />
<meta property="og:title" content="After Putin&#039;s offer to share notes, ranking House Intel Democrat Schiff is &#039;running out of expletives&#039;" />
<link href="http://mediad.publicbroadcasting.net/p/shared/pmp/201705/da3c498f-aa79-4ecc-aa02-f0c38318224e.jpg" rel="image_src" />
<meta name="description" content="Russian President Vladimir Putin offered Wednesday to share with US Congress his records of that now fateful White House meeting between President Donald" />
<meta property="og:description" content="Russian President Vladimir Putin offered Wednesday to share with US Congress his records of that now fateful White House meeting between President Donald" />
<meta property="og:image" content="http://kazu.org/sites/shared/pmp/styles/medium/pmpshared/201705/da3c498f-aa79-4ecc-aa02-f0c38318224e.jpg" />
<link rel="shortcut icon" href="http://mediad.publicbroadcasting.net/p/kazu/files/favicon_3.ico" type="image/vnd.microsoft.icon" />
<link rel="shortcut icon" href="http://mediad.publicbroadcasting.net/p/kazu/files/201507/favicon_fid.ico" type="image/vnd.microsoft.icon" />
<meta content="After Putin&amp;#039;s offer to share notes, ranking House Intel Democrat Schiff is &amp;#039;running out of expletives&amp;#039;" about="/post/after-putins-offer-share-notes-ranking-house-intel-democrat-schiff-running-out-expletives" property="dc:title" />
<meta property="twitter:site" content="@903KAZU" />
<meta property="twitter:card" content="summary" />
<meta name="datePublished" content="2017-05-17" />
<meta name="pmp_guid" content="a1d3862a-248a-4057-bcf0-2e080c12a366" />
<link rel="shortlink" href="/node/88944" />
<meta name="has_audio" content="1" />
<link rel="canonical" href="/post/after-putins-offer-share-notes-ranking-house-intel-democrat-schiff-running-out-expletives" />
<script type="text/javascript">var _sf_startpt=(new Date()).getTime();</script>
<meta name="Generator" content="Drupal 7 (http://drupal.org)" />
<meta name="programs" content="The World on KAZU" />
<meta name="category" content="News" />
<meta name="keywords" content="" />
<meta name="org_id" content="0" />
<meta name="author" content="Joyce Hackel" />
<meta name="nid" content="88944" />
<meta name="wordCount" content="879" />
    <title>After Putin&#039;s offer to share notes, ranking House Intel Democrat Schiff is &#039;running out of expletives&#039; | 90.3 KAZU</title>
    <link type="text/css" rel="stylesheet" href="http://kazu.org/sites/kazu.org/files/css/css_zXr1pRkjUmFHX10b6Pv5_DqzyewvdLNQ8QgccGQIRQQ.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://kazu.org/sites/kazu.org/files/css/css_ZFlaYqkiQzTmlBPX4mQeT33IFQX3nR-zpGlyqFhtTNM.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://kazu.org/sites/kazu.org/files/css/css_XHTm2cMU6sD6pzlNwtS19lgDRK8GjAz14nQaxKhle30.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://kazu.org/sites/kazu.org/files/css/css_uY1_bHNTrAu2UuUwumZ6AuPc2Egu5fV5FiJ2-fv7ySk.css" media="all" />
<style type="text/css" media="all">
<!--/*--><![CDATA[/*><!--*/
.header-region-outer{background-color:#50748a;}@media screen and (min-width:1024px){.header-region-outer{background-image:url(http://mediad.publicbroadcasting.net/p/kazu/files/201606/background_fid.jpg);background-position:center top;background-size:cover;background-repeat:no-repeat;}}.branding .tagline{color:#35465C;}.branding .listen-live-toggle > a,.branding .header-utility > a,.branding .header-utility > a.trigger-nav{color:#ffffff;}@media screen and (min-width:641px){.branding .trigger-nav{background:#63703a;}}@media screen and (max-width:640px){.branding .header-utility > a.trigger-nav,.active-menu .branding .header-utility > a.trigger-nav{color:#ffffff;}}#listen-live .listen-live-toggle{background-color:#c1aa6f;}#listen-live .listen-live-btn{background-color:transparent;color:#ffffff;}@media screen and (min-width:640px){#listen-live .listen-live-btn{background-color:#c1aa6f;}}.branding .give{background:#DF3939;}

/*]]>*/-->
</style>
<link type="text/css" rel="stylesheet" href="http://fonts.googleapis.com/css?family=Lato:300,700,700italic,900,italic,regular&amp;subset=latin" media="all" />
<link type="text/css" rel="stylesheet" href="http://kazu.org/sites/kazu.org/files/css/css_eRVoz-O-Udn2obFI7TLsFyeBRhxeGJDVXmIlZ64ZQsg.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://kazu.org/sites/kazu.org/files/css/css_SWo6tZlpCPjnhbZDAS4xgnCAofi51J7pbtu4SD2fIug.css" media="all" />
    <script type="text/javascript" src="http://mediad.publicbroadcasting.net/p/kazu/files/js/js_xSpMA4ArVcBKOZ43sPqNRk0gxQZdDVifw27pIUCzWU0.js"></script>
<script type="text/javascript" src="http://mediad.publicbroadcasting.net/p/kazu/files/js/js_P9u0bgloveAIlc2kutVCUB_xMaRV3YHWhSVHD3IN5tM.js"></script>
<script type="text/javascript" src="http://mediad.publicbroadcasting.net/p/kazu/files/js/js_-WcrGf3pH5GnSWA1Y-B28tyjknNjFr4asJklCZQ5NUA.js"></script>
<script type="text/javascript" src="http://mediad.publicbroadcasting.net/p/kazu/files/js/js_nkSUZ02s_aG347r7rbDTEbwk8rVKFMn8hgmSyQK5N1k.js"></script>
<script type="text/javascript" src="//www.googletagservices.com/tag/js/gpt.js"></script>
<script type="text/javascript" src="http://mediad.publicbroadcasting.net/p/kazu/files/js/js_SEp4NIM2PD1RhjC3_NDUBbtmniv0x9btV0ghmYjWhNo.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
(function() {var ga = document.createElement("script");ga.type = "text/javascript";ga.async = true;ga.src="//stream.publicbroadcasting.net/analytics/aakx.js";var s = document.getElementsByTagName("script")[0];s.parentNode.insertBefore(ga, s);})();
//--><!]]>
</script>
<script type="text/javascript" src="http://mediad.publicbroadcasting.net/p/kazu/files/js/js_FyJuo1e2Es-uJ5tABbNBqzk3V7BVne0hueY_EEWorU8.js"></script>
<script type="text/javascript">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</script>
    <meta name="viewport" content="width=device-width">
  </head>

  <body class="html not-front not-logged-in page-node page-node- page-node-88944 node-type-post fixed-header" >
    <header role="banner" class="header">
  <div class="skiptocontent"><a href="#main-content">skip to main content</a></div>
    <div class="region region-header">
    <div id="block-baby-bear-baby-bear-header" class="block block-baby-bear">

    
  <div class="content">
    
<div class="header-region-outer">
  <section class="header-region-inner row">
    <div class="branding large-12 columns">
      <div class="brand-inner-wrapper">
        <a href="/" rel="home" class="logo" title="90.3 KAZU Home"><img typeof="foaf:Image" src="http://mediad.publicbroadcasting.net/p/kazu/files/201605/logo_350w.png" alt="90.3 KAZU logo" title="90.3 KAZU Home" /></a>         <div class="tagline">
                  </div>
      </div>
      <div class="header-utility">
        <a class="trigger-nav" href="#">
          <span class="icon-list"></span>
          <span class="menu-text">Site Menu</span>
        </a>
        <a class="give" href="https://support.kazu.org/donate" >
  Donate</a>
      </div>
    </div>
  </section>
</div>
  </div>
</div>
  </div>
</header>
    <div class="nav-wrapper mobile">
      <nav>
        <div class="top-bar contain-to-grid" data-topbar>
          <ul class="title-area">
            <li class="toggle-topbar menu-icon">
              <a href="#">Menu</a>
            </li>
          </ul>
          <section class="top-bar-section">
            <div class="table-queue" id="table-queue-fleximenu">
  <ul  class="menu dropdown">
<li class="dd has-dropdown not-click">
<a href="http://kazu.org/people/capacity/staff">About</a>
<ul  class="dropdown">
<li class="left">
<a href="http://kazu.org/contact">Contact</a>
</li>
<li class="left">
<a href="http://kazu.org/people/capacity/staff">Staff</a>
</li>
<li class="left">
<a href="http://kazu.org/people/capacity/hosts">Hosts</a>
</li>
<li class="left">
<a href="http://mediad.publicbroadcasting.net/p/kazu/files/201704/LocalContentandServicesReport2016.pdf">Local Content and Service Report</a>
</li>
<li class="left">
<a href="http://kazu.org/governance">Governance</a>
</li>
<li class="left">
<a href="http://mediad.publicbroadcasting.net/p/kazu/files/kazu_diversity_statement_update_2016.pdf">CPB Annual Diversity Report</a>
</li>
<li class="left">
<a href="http://kazu.org/financial-statements">Financial Statements</a>
</li>
<li class="left">
<a href="http://kazu.org/volunteer">Volunteer</a>
</li>
</ul>
</li>
<li class="dd has-dropdown not-click">
<a href="https://support.kazu.org/donate">Support</a>
<ul  class="dropdown">
<li class="left">
<a href="https://support.kazu.org/donate">Donate to Become a KAZU Member</a>
</li>
<li class="left">
<a href="http://kazu.org/underwriting">Business Sponsorship/Underwriting</a>
</li>
<li class="left">
<a href="http://kazu.careasy.org/HOME.html">Vehicle Donation</a>
</li>
<li class="left">
<a href="http://kazu.org/topic/donating-kazu">Donate Stock</a>
</li>
<li class="left">
<a href="http://kazu.org/matching-gifts">Employer Matching Gifts</a>
</li>
<li class="left">
<a href="http://kazu.org/gift-planning-and-making-bequest-kazu-endowment">Planned Giving</a>
</li>
<li class="left">
<a href="http://kazu.org/spring-2017-thank-you-gifts">Member Thank You Gifts</a>
</li>
<li class="left">
<a href="http://kazu.org/kazu-salon-series">Salon Series</a>
</li>
<li class="left">
<a href="http://kazu.org/kazu-movieclub">Movie Club</a>
</li>
</ul>
</li>
<li class="dd has-dropdown not-click">
<a href="http://kazu.org/programs">Programs</a>
<ul  class="dropdown">
<li class="left">
<a href="http://kazu.org/schedule/week">Program Schedule</a>
</li>
<li class="left">
<a href="http://kazu.org/programs">Program Guide</a>
</li>
</ul>
</li>
<li class="dd has-dropdown not-click">
<a href="http://kazu.org/term/local">Local News</a>
<ul  class="dropdown">
<li class="left">
<a href="http://kazu.org/term/local">Local Stories</a>
</li>
<li class="left">
<a href="http://kazu.org/topic/local-programs-6">Local Programs</a>
</li>
</ul>
</li>
<li>
<a href="http://kazu.org/community-calendar#stream/0">Community Calendar</a>
</li>
<li>
<a href="http://kazu.org/kazu-media-sponsorships#stream/0">Sponsored Events</a>
</li>
<li>
<a href="http://kazu.org/ways-listen#stream/0">Ways to Listen</a>
</li>
<li>
<a href="http://kazu.org/search/google">Search</a>
</li>
<li>
<a href="http://kazu.org/listen-kazus-hd2-classical-music-station#stream/0">KAZU HD2 Classical Music Stream - Click Here</a>
</li>
</ul>
</div>
          </section>
        </div>
      </nav>
    </div>
      <div class="region region-persistent">
    <div id="block-audity-audity" class="block block-audity">

    
  <div class="content">
      </div>
</div>
  </div>
    <div id="page-wrapper">
            <div id="page-document" role="document" class="page">
  <div class="nav-wrapper">
    <nav>
      <div class="top-bar contain-to-grid" data-topbar>
        <ul class="title-area">
          <li class="toggle-topbar menu-icon">
            <a href="#">Menu</a>
          </li>
        </ul>
        <section class="top-bar-section">
          <div class="table-queue" id="table-queue-fleximenu">
  <ul  class="menu dropdown">
<li class="dd has-dropdown not-click">
<a href="http://kazu.org/people/capacity/staff">About</a>
<ul  class="dropdown">
<li class="left">
<a href="http://kazu.org/contact">Contact</a>
</li>
<li class="left">
<a href="http://kazu.org/people/capacity/staff">Staff</a>
</li>
<li class="left">
<a href="http://kazu.org/people/capacity/hosts">Hosts</a>
</li>
<li class="left">
<a href="http://mediad.publicbroadcasting.net/p/kazu/files/201704/LocalContentandServicesReport2016.pdf">Local Content and Service Report</a>
</li>
<li class="left">
<a href="http://kazu.org/governance">Governance</a>
</li>
<li class="left">
<a href="http://mediad.publicbroadcasting.net/p/kazu/files/kazu_diversity_statement_update_2016.pdf">CPB Annual Diversity Report</a>
</li>
<li class="left">
<a href="http://kazu.org/financial-statements">Financial Statements</a>
</li>
<li class="left">
<a href="http://kazu.org/volunteer">Volunteer</a>
</li>
</ul>
</li>
<li class="dd has-dropdown not-click">
<a href="https://support.kazu.org/donate">Support</a>
<ul  class="dropdown">
<li class="left">
<a href="https://support.kazu.org/donate">Donate to Become a KAZU Member</a>
</li>
<li class="left">
<a href="http://kazu.org/underwriting">Business Sponsorship/Underwriting</a>
</li>
<li class="left">
<a href="http://kazu.careasy.org/HOME.html">Vehicle Donation</a>
</li>
<li class="left">
<a href="http://kazu.org/topic/donating-kazu">Donate Stock</a>
</li>
<li class="left">
<a href="http://kazu.org/matching-gifts">Employer Matching Gifts</a>
</li>
<li class="left">
<a href="http://kazu.org/gift-planning-and-making-bequest-kazu-endowment">Planned Giving</a>
</li>
<li class="left">
<a href="http://kazu.org/spring-2017-thank-you-gifts">Member Thank You Gifts</a>
</li>
<li class="left">
<a href="http://kazu.org/kazu-salon-series">Salon Series</a>
</li>
<li class="left">
<a href="http://kazu.org/kazu-movieclub">Movie Club</a>
</li>
</ul>
</li>
<li class="dd has-dropdown not-click">
<a href="http://kazu.org/programs">Programs</a>
<ul  class="dropdown">
<li class="left">
<a href="http://kazu.org/schedule/week">Program Schedule</a>
</li>
<li class="left">
<a href="http://kazu.org/programs">Program Guide</a>
</li>
</ul>
</li>
<li class="dd has-dropdown not-click">
<a href="http://kazu.org/term/local">Local News</a>
<ul  class="dropdown">
<li class="left">
<a href="http://kazu.org/term/local">Local Stories</a>
</li>
<li class="left">
<a href="http://kazu.org/topic/local-programs-6">Local Programs</a>
</li>
</ul>
</li>
<li>
<a href="http://kazu.org/community-calendar#stream/0">Community Calendar</a>
</li>
<li>
<a href="http://kazu.org/kazu-media-sponsorships#stream/0">Sponsored Events</a>
</li>
<li>
<a href="http://kazu.org/ways-listen#stream/0">Ways to Listen</a>
</li>
<li>
<a href="http://kazu.org/search/google">Search</a>
</li>
<li>
<a href="http://kazu.org/listen-kazus-hd2-classical-music-station#stream/0">KAZU HD2 Classical Music Stream - Click Here</a>
</li>
</ul>
</div>
        </section>
      </div>
    </nav>
  </div>

  <div id="player" class="player">
      </div>

  
      <section class="pre-content">
      <div>
          <div class="region region-pre-content">
    <div id="block-pi-responsive-ads-mobile-1" class="block block-pi-responsive-ads">

    
  <div class="content">
      </div>
</div>
  </div>
      </div>
    </section>
  
  
  
  <div class="row">
    <main id="content" role="main" class="main-content small-12 columns">
      <article class="story">
        <a id="main-content"></a>
        
                                    
        
        
        
        
        
        
                    <div class="region region-content">
    <div id="block-system-main" class="block block-system">

    
  <div class="content">
    <div id="node-88944" class="node node-post node-promoted full row" about="/post/after-putins-offer-share-notes-ranking-house-intel-democrat-schiff-running-out-expletives" typeof="sioc:Item foaf:Document">
  <div class="small-12 columns">
        
          <div class='post-program post-program-top'>
        <div class="field field-name-field-related-program field-type-node-reference field-label-inline clearfix"><div class="field-label">Related Program:&nbsp;</div><div class="field-items"><div class="field-item even"><a href="/programs/world-kazu">The World on KAZU</a></div></div></div>      </div>
    
    <h1 itemprop="name" class="post-title">
      After Putin&#039;s offer to share notes, ranking House Intel Democrat Schiff is &#039;running out of expletives&#039;    </h1>

  	
    
          <div class="by-date">
        <span class="submitted"><span property="dc:date dc:created" content="2017-05-17T15:39:48-07:00" datatype="xsd:dateTime" rel="sioc:has_creator"><span class="submitted-label">By</span> <span class="name">Joyce Hackel</span></span></span>
        <i class="bullet">&#8226;</i>
        <span class="pub-date">2 hours ago</span>
      </div>
    
    <div class="row">
      <div class="large-2 columns sharing-and-programs">
                  <div class='post-program post-program-side'>
            <div class="field field-name-field-related-program field-type-node-reference field-label-inline clearfix"><div class="field-label">Related Program:&nbsp;</div><div class="field-items"><div class="field-item even"><a href="/programs/world-kazu">The World on KAZU</a></div></div></div>          </div>
        
        <div class="social-share clearfix"><a href="http://twitter.com/intent/tweet?url=http%3A%2F%2Fwww.tinyurl.com%2Fmo9f5aa&amp;text=After%20Putin%27s%20offer%20to%20share%20notes%2C%20ranking%20House%20Intel%20Democrat%20Schiff%20is%20%27running%20out%20of%20expletives%27" class="social-share-item twitter" title="Tweet" target="_blank">Tweet</a><a href="http://facebook.com/sharer.php?u=http%3A%2F%2Fwww.tinyurl.com%2Fmo9f5aa&amp;t=After%20Putin%27s%20offer%20to%20share%20notes%2C%20ranking%20House%20Intel%20Democrat%20Schiff%20is%20%27running%20out%20of%20expletives%27" class="social-share-item facebook" title="Share" target="_blank">Share</a><a href="https://plus.google.com/share?url=http%3A%2F%2Fwww.tinyurl.com%2Fmo9f5aa" class="social-share-item googleplus" title="Google+" target="_blank">Google+</a><a href="mailto:?subject=After%20Putin%27s%20offer%20to%20share%20notes%2C%20ranking%20House%20Intel%20Democrat%20Schiff%20is%20%27running%20out%20of%20expletives%27&amp;body=http%3A%2F%2Fwww.tinyurl.com%2Fmo9f5aa" class="social-share-item email" title="Email" target="_blank">Email</a></div>      </div>

      <div class="medium-10 medium-pull-1 large-8 large-pull-2 columns post-body-container" >
        <div class="post-body">
          <div class="field field-name-field-image-gallery field-type-image field-label-hidden"><div class="field-items"><div class="field-item even"><ul class="gallery no-bullet"><li>
  <figure>
    <a title="&lt;p&gt;Rep. Adam Schiff, a California Democrat says if Congress doesn't get the documents it needs to investigate Trump's actions, he backs issuing subpoenas.  &lt;/p&gt;
" href="/sites/shared/pmp/styles/x_large/pmpshared/201705/da3c498f-aa79-4ecc-aa02-f0c38318224e.jpg" class="noexit lightbox">
      <img src="/sites/shared/pmp/styles/medium/pmpshared/201705/da3c498f-aa79-4ecc-aa02-f0c38318224e.jpg"  alt="R">
          </a>
    <div class="image-meta">
  <figcaption>
    <div class="caption"><p>Rep. Adam Schiff, a California Democrat says if Congress doesn't get the documents it needs to investigate Trump's actions, he backs issuing subpoenas.  </p>
</div>
    <div class="attribution">
  <span class="credit">Aaron P. Bernstein/Reuters&nbsp;</span>
    <span class="agency"></span>
</div>
  </figcaption>
</div>
  </figure>
</li>
</ul></div></div></div>

<div class="audio-container">
  <div id="jp-interface--591cf452797bb" class="jp-interface">
    <div id="post-audio--591cf452797bb" class="jp-player" jp-instance="-591cf452797bb"></div>

    <div class="playpause">
      <a href="http://www.podtrac.com/pts/redirect.mp3/cdn.pri.org/sites/default/files/pris-world/segment-audio/2017051701.mp3" title="" class="jp-play"></a>      <a class="jp-pause"></a>
    </div>

    <div class="audio-meta">
      <div class="listen-text-box">
        <div class="listen-text">Listen </div>
        <div class="listening-text">Listening...</div>
      </div>

      <div class="jp-controls">
        <div class="jp-progress">
          <div id="seekbar" class="jp-seek-bar">
            <div id="playbar" class="jp-play-bar">
              <div class="scrubber">
              </div>
            </div>
          </div>
        </div>
      </div>

      <div class="duration-wrapper">
        <div class="jp-custom-current-time"></div>
        <span class="divider">&#47;</span>
        <div class="jp-custom-duration"></div>
      </div>

    </div>
          <div class="audio-caption">2</div>
      </div>
</div>
<div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even" property="content:encoded"><p>Russian President Vladimir Putin offered Wednesday to share with US Congress his records of that now fateful White House meeting between President Donald Trump and some of Russia's top diplomats.</p> <p>Rep. Adam Schiff, a California Democrat and the ranking member of the House Intelligence Committee, doesn't know whether to find the offer ironic, amusing or disturbing.</p> <p>"I'm running out of adjectives and expletives for the situation," Schiff says. "You have probably the last person that the president wants to vouch for him, vouching for him, and that's Vladimir Putin. You know things have gotten pretty bad when you're asking for Putin to lend you credibility on the Russia issue."</p> <p>The World spoke to Schiff on Wednesday. The interview has been edited for clarity.</p> <p> The World: Has former FBI Director James Comey said anything to you or the Intelligence Committee that has indicated interference from President Trump in an investigation? If so, what's been said? </p><p>Adam Schiff: Well, he certainly didn't describe the meeting that was <a href="https://www.nytimes.com/2017/05/16/us/politics/james-comey-trump-flynn-russia-investigation.html" target="_blank">reported in the New York Times</a>. I wasn't aware of these memoranda until I read that article. And we've had the [former FBI] director come in twice just within the last couple months. We would never have imagined we'd need him to come back so soon before the Congress. But we do need to get to the bottom of this. And between the account of the director as it's reported and what the president has been relaying, I think people would probably have a lot more faith in the account coming from the director of the FBI.</p> <p> Based on what you already know about Mike Flynn's trips to Russia, are you inclined to believe there is fire behind the notes that James Comey took after his meetings with Trump back in February, or is it probably just more smoke? </p><p>I think these allegations are the most concerning so far. The president's own admission a week ago that he fired Comey because of the Russia investigation and that in fact he had asked Comey about whether he was a subject of investigation at the time, where he acknowledged Comey was worried about keeping his job — those were serious. This is yet again another indication that there's a pattern here. Now this is all on the basis of public reports that have not been confirmed, so I don't think we should get too far ahead. We need to make sure that we find out whether these reports are true, what these memoranda say, if indeed there are memoranda of other conversations between the FBI director and the president that might reveal other improper conduct that sheds light on the president's motivations, because key to figuring out whether there was obstruction [of justice] is what the president's intent may have been.</p> <p> Russia issued the first photos of Trump, Russia's Foreign Minister Sergei Lavrov, and Russia's Ambassador to the US Sergei Kislyak meeting in the Oval Office. Russia has now said they can provide transcripts of that meeting. What are your thoughts on how the White House is handling intelligence?  </p><p>Well, this is really breathtaking, that the account, the fact[s], the photos of this meeting are coming from the Russians and the Russians are now offering transcripts. After all, the Russians still deny that they were involved in hacking our democratic institutions. So the Russians have no credibility here, but it is more than a bit ironic, amusing, disturbing. As I like to say, I'm running out of adjectives and expletives for the situation that the Russians are offering to provide the evidence of what went on in the White House. </p> <p> Are subpoenas the next step?  </p><p>If the documents are provided voluntarily, then absolutely. I have to think that the FBI is going to provide these documents willingly and I have to think that [former] Director Comey will come before the Congress willingly and I think we need to do both as soon as possible.</p> <p> Rep. Schiff, how would you describe the moment in which we're living? </p><p>It's [moving] at a breathtaking pace and of course everyone is asking quite rightly, "Where does this all lead?" This most recent allegation is among the most serious, that the president of the United States told the FBI director to essentially drop an investigation into one of his top aides, the ... former national security adviser. That's a very serious business, which of course raises the prospect of whether there was active interference or obstruction of justice. I think there will be some pretty powerful evidence if that's the case in the form of contemporaneous notes and memorand[a] written by the FBI director, and Congress certainly needs to get ahold of those. I think we need to bring the director back in in short order to testify before Congress.</p>  <p> <br /></p><p>From PRI's The World ©2017 <a href="http://www.pri.org">PRI</a></p> <img id="pri-insights" src="//api.pri.org/insights/?story=https%3A%2F%2Fwww.pri.org%2Fstories%2F2017-05-17%2Frussia-offers-provide-evidence-what-went-white-house-how-wild&amp;feed=pmp" /></div></div></div><div class="social-share bottom"><a href="http://twitter.com/intent/tweet?url=http%3A%2F%2Fwww.tinyurl.com%2Fmo9f5aa&amp;text=After%20Putin%27s%20offer%20to%20share%20notes%2C%20ranking%20House%20Intel%20Democrat%20Schiff%20is%20%27running%20out%20of%20expletives%27" class="social-share-item twitter" title="Tweet" target="_blank">Tweet</a><a href="http://facebook.com/sharer.php?u=http%3A%2F%2Fwww.tinyurl.com%2Fmo9f5aa&amp;t=After%20Putin%27s%20offer%20to%20share%20notes%2C%20ranking%20House%20Intel%20Democrat%20Schiff%20is%20%27running%20out%20of%20expletives%27" class="social-share-item facebook" title="Share" target="_blank">Share</a><a href="https://plus.google.com/share?url=http%3A%2F%2Fwww.tinyurl.com%2Fmo9f5aa" class="social-share-item googleplus" title="Google+" target="_blank">Google+</a><a href="mailto:?subject=After%20Putin%27s%20offer%20to%20share%20notes%2C%20ranking%20House%20Intel%20Democrat%20Schiff%20is%20%27running%20out%20of%20expletives%27&amp;body=http%3A%2F%2Fwww.tinyurl.com%2Fmo9f5aa" class="social-share-item email" title="Email" target="_blank">Email</a></div>        </div>

        <div class="related">
                  </div>
      </div>
    </div>
      </div>
</div>
  </div>
</div>
  </div>
              </article>
    </main>
  </div>

  
  <div class="bottom-ads">
    <div class="bottom-ads-inner"></div>
  </div>
</div>

<footer class="footer" role="contentinfo">
  <div class="row">
    <div class="footer-affiliate-container small-centered columns">
                  <div class="region region-footer">
    <div id="block-pi-table-queue-partnerfooter" class="block block-pi-table-queue">

    
  <div class="content">
    <div class="table-queue" id="table-queue-partnerfooter">
  <p class="partnerslabel">
  </p>
<div class="item-list"><ul class="partner-logos"><li class="first"><img typeof="foaf:Image" src="http://mediad.publicbroadcasting.net/p/kazu/files/styles/partner_footer_logo/public/201507/apm-logo.png" alt="" title="" /></li>
<li><img typeof="foaf:Image" src="http://mediad.publicbroadcasting.net/p/kazu/files/styles/partner_footer_logo/public/201507/bbc-logo.png" alt="" title="" /></li>
<li><img typeof="foaf:Image" src="http://mediad.publicbroadcasting.net/p/kazu/files/styles/partner_footer_logo/public/201507/npr-logo.png" alt="" title="" /></li>
<li><img typeof="foaf:Image" src="http://mediad.publicbroadcasting.net/p/kazu/files/styles/partner_footer_logo/public/201507/pri-logo.png" alt="" title="" /></li>
<li class="last"><img typeof="foaf:Image" src="http://mediad.publicbroadcasting.net/p/kazu/files/styles/partner_footer_logo/public/201507/prx-logo.png" alt="" title="" /></li>
</ul></div></div>
  </div>
</div>
<div id="block-pi-table-queue-auxiliarylinksfooter" class="block block-pi-table-queue">

    
  <div class="content">
    <div class="table-queue" id="table-queue-auxiliarylinksfooter">
  <div class="item-list"><ul class="auxiliary-links"><li class="first"><span>&copy; 2017 90.3 KAZU</span></li>
<li><a href="http://kazu.org/contact" target="_self">Contact Us</a></li>
<li><a href="http://events.publicbroadcasting.net/kazu/events.eventsmain" target="_self">Events Calendar</a></li>
<li><a href="http://kazu.org/terms-use" target="_self">Terms of Use</a></li>
<li><a href="http://kazu.org/privacy-policy" target="_self">Privacy Policy</a></li>
<li><a href="http://kazu.org/eeo" target="_self">EEO</a></li>
<li class="last"><a href="https://csumb.edu/" target="_blank">A Community Service of California State University Monterey Bay</a></li>
</ul></div></div>
  </div>
</div>
  </div>
          </div>
  </div>
</footer>
      <script type="text/javascript">
  var _sf_async_config=Drupal.settings.chartbeat;
  (function(){
    function loadChartbeat() {
      window._sf_endpt=(new Date()).getTime();
      var e = document.createElement('script');
      e.setAttribute('language', 'javascript');
      e.setAttribute('type', 'text/javascript');
      e.setAttribute('src',
         (("https:" == document.location.protocol) ? "https://s3.amazonaws.com/" : "http://") +
         "static.chartbeat.com/js/chartbeat.js");
      document.body.appendChild(e);
    }
    var oldonload = window.onload;
    window.onload = (typeof window.onload != 'function') ?
       loadChartbeat : function() { oldonload(); loadChartbeat(); };
  })();
</script><script type="text/javascript">
<!--//--><![CDATA[//><!--
 (function ($) { $(document).foundation({ topbar: { custom_back_text: true, back_text: 'back', mobile_show_parent_link: true } }); }(jQuery));
//--><!]]>
</script>
    </div>
  <script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"15ba4da3e8","applicationID":"1108724","transactionName":"NlMBMhAECEZRAU1eDg8ZIgUWDAlbHwxWUwQ+RgIBBzoQXFUV","queueTime":0,"applicationTime":1059,"atts":"GhQCRFgeG0g=","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>
